Author Topic: Custom tag for key notation  (Read 7244 times)

SHODAN

  • Newbie
  • *
  • Posts: 19
I use Mixed In Key for tagging keys to FLAC & mp3 files.

If I select an mp3 file from windows explorer, go to properties, then ID-Tag, I can see that the key definition is "Initial key". in the FLAC file properties, the key definition is "INITIALKEY" (no space).

I created a custom tag in MusicBee. I want this tag to represent the key value of both mp3 and FLAC files. but for some reason, only the FLAC files display the key value in my custom column. I tried changing the id3 to "TKEY", but that didn't work. the definition "%Initial key%" works just fine in foobar.

screenshot:

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
Initial Key is already configured in the Custom Tags list.  Try removing your new custom tag and using the one already in the "save to music file as tag" list.  If it's still not working correctly, try adding a key to an MP3 and look at the Tag Inspector to see where it goes.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

SHODAN

  • Newbie
  • *
  • Posts: 19
OK, I'll try that. here is the view from my tag inspector and custom tags list. I will change 'Key' to 'Initial Key' from the drop down menu and re-scan my library.



SHODAN

  • Newbie
  • *
  • Posts: 19
OK, after removing the custom tag and re-scanning my library, the keys for mp3 files are now displaying. however, the keys for FLAC files are not displaying anymore. this is the reason I created a custom tag in the first place.

the Initial key tag in MusicBee does not display the key values of FLAC files which I tagged with MixedInKey. my own custom tag, called "Key", is able to display those values, but fails to display the values for mp3 files.  my tag definition for FLAC files is INITIALKEY and this works fine. however, the tag definitions TKEY and INITIAL KEY do not work for mp3. so my problem remains the same: how can I set up a custom tag which can display the key values for both mp3 and FLAC? what tag definition does MusicBee use for mp3 initial key?
Last Edit: May 12, 2016, 08:55:13 AM by SHODAN

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3766
  • MB Version: 3.5.8211 P
Looking at MB Configuration.xml, 'Initial Key' is looking for "INITIAL KEY" in flac files.
This is probably at typo as most vorbisComments don't have spaces between words.

2 options:

put a request in the wish list for Steven to edit the 'Initial Key' tag

or (at your own risk)

make sure MB is closed
make a copy of your Configuration.xml file (found in your main MusicBee installation folder)
open the original Configuration.xml file with a text editor, change "INITIAL KEY" to "INITIALKEY" for the vorbisComments entry
save the changed file and re-start MB

one of the problems with the second option is that if Steven makes an edit to the config in an update, it will override your changed file.
Last Edit: May 12, 2016, 09:37:22 AM by Bee-liever
MusicBee and my library - Making bee-utiful music together

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
You can find out what tag MB uses for either file type by adding a tag in the field and then checking the tag inspector.

In any case, I suggest you post on the wishlist thread for Steven to update the flac version of initial key to read the frame as you had it configured
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

SHODAN

  • Newbie
  • *
  • Posts: 19
thanks for the helpful replies. I put in a request on the wish list.

I'm seeing some funny things happen in the tag inspector...

1) inside MusicBee preferences, I set my custom tag to "save to music file as tag" key.
2) I tag an mp3 file using MixedInKey
3) I import the file to MusicBee and inspect the tags:
        Name                    Tag Code                    Value
        INITIAL KEY           TKEY                            2A

4) the "key" field inside the Tags (2) remains blank.
5) I manually edit the "key" field inside Tags (2). I enter "9A" and save the changes.
6) I view the tag inspector again:
        Name                    Tag Code                    Value
        INITIAL KEY           TKEY                            2A
        KEY                        TXXX/TKEY                  9A

7) now I open the mp3 in foobar / serato. both programs read the key as 2A.
8 ) I clear the "key" field inside Tags (2). It is now blank again.
9) inside MusicBee preferences, I set my custom tag to "save to music file as tag" initial key.
10) re-scan library.
11) the "key" field inside the Tags (2) now displays 2A.

so, when a custom tag is set to "save to music file as tag" key, it fails to read/write the actual id3 tag "INITIAL KEY". however, when a custom tag is set to "save to music file as tag" initial key, it reads/writes the actual id3 tag "INITIAL KEY" just fine.  I'm wondering what the difference is between the tag codes "TXXX/TKEY" and "TKEY"... and overall I am just very puzzled :/

do you think if I change the custom tag display name to "Initial key", or the custom tag identifier to "Initial key", this might fix the problem?

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3766
  • MB Version: 3.5.8211 P
You can't reference an existing tag with a custom tag.
Since "Initial Key" already exists in MB and uses TKEY, no other tag can use that.
MB will prepend TXXX/ to your use of TKEY in the custom tag to avoid conflicts.

You either need to wait for Steven to do the config change in the wishlist or, do a manual edit of it to have the "Initial Key" work correctly.
MusicBee and my library - Making bee-utiful music together

SHODAN

  • Newbie
  • *
  • Posts: 19
config edit did the trick. real thanks for the help!

alec.tron

  • Hero Member
  • *****
  • Posts: 730
I just had the same issue, i.e. trying to figure out why my custom Key tag doesn't get read on mp3 files... and then why flac files don't work (as they do everywhere else for key field) when trying to use the default MB initial key tag...
Thanks for the 'trick' psychoadept!

Out of curiousity, and since Serato & Traktor both write/read flac key tag as "INITIALKEY", and mpeg as well as ape2 are both set to INITIALKEY / InitialKey respectively as well:

<Tag id="Initial Key" id3v23="TKEY" id3v24="TKEY" wma="WM/InitialKey" vorbisComments="INITIAL KEY" mpeg="INITIALKEY" ape2="InitialKey" />

Why is vorbisComments="INITIAL KEY" not vorbisComments="INITIALKEY" ?
Is there any program that requires vorbisComments key information to be written as "INITIAL KEY" ?
I'm asking as I only know of programs that require the opposite.... and if there's no actual use case for vorbisComments="INITIAL KEY", it would be great to have this adjusted on MB core on the next updates to be vorbisComments="INITIALKEY" instead.

Cheers.
c.

alec.tron

  • Hero Member
  • *****
  • Posts: 730
Hm. After the forum was down for the last hour or longer - some threads, like this one here (all posts above are now 'centered' formatted), seem to have gotten hit and saved anew with weird centered formatting like - not sure where to flag this...?

Churs.
c.

ps. Nevermind, after posting this, this threads post were not 'centered' formatted anymore. Odd...

alec.tron

  • Hero Member
  • *****
  • Posts: 730
Looking at MB Configuration.xml, 'Initial Key' is looking for "INITIAL KEY" in flac files.
This is probably at typo as most vorbisComments don't have spaces between words.

Could this 'typo' be fixed please ?
Or, if this is a no-fix, a reply would be nice plus maybe an explanation as to why this should be different when no one seems to see any value in having "INITIAL KEY" instead of the expected "INITIALKEY" for flac/off vorbis tage types ?

Cheers.
c.

SHODAN

  • Newbie
  • *
  • Posts: 19
I just upgraded from 2.something to the latest 3.0.6335

forgot all about this annoying bug and the work-around. so I spent the evening mulling over the same problem I complained about a year ago. can't believe this hasn't been fixed yet! glad I made a thread about it at least ;D

arbor_mute

  • Jr. Member
  • **
  • Posts: 46

phred

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 7867
Fix strongly needed for this issue!!
A fix is supplied in Reply #4.
Download the latest MusicBee v3.4 patch from here.
Download the latest MusicBee v3.5 beta patch from here.
Unzip into your MusicBee directory and overwrite existing files.

----------
Check out the MusicBee Wiki.
How to post screenshots is here