Author Topic: Milkdrop Visualiser Support  (Read 111284 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 30818
I honestly cant see how that error could have happened but in any case I have put in handling to ensure only a valid colour can be set.
In terms of the keyboard handling, I had to go back to v2.5 to find a version that worked as expected. A lot has changed and its very difficult to figure out why its not working so I am going to leave this unsolved for now.


redwing

  • Guest
With the new patch, the error no longer shows up, but transition from desktop mode to normal window still doesn't work properly. GUI is often broken or not responding. The only workaround I found is click on restore button and then maximize again, then visualizer tab shows up properly with milkdrop working in it.

redwing

  • Guest
When you have time to revisit this, I hope you consider removing the hard-coded cap on the framerate. Currently it's capped to 40FPS, which is better than 30FPS of v2.5, but I don't see why such restriction is needed. If it has to for some reason, please allow it at least up to 60FPS as the most common refresh rate of laptop monitors is 60Hz.

lux1o

  • Jr. Member
  • **
  • Posts: 60
i cant exit full screen pressing esc

only double click an then goes to window mode

thenks

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
when I select Milkdrop 2.2 I just get a blank screen.

Do you get any error messages when you run milkdrop?
Also try right-clicking on the screen and try other modes (desktop/full screen) to see if they work.
Try disabling all plugins (including VSTs) and other running programs to avoid any possible conflicts.

If the issue persists, can you post a screenshot of how it looks when you're playing a song on the visualizer tab?


Thanks, I'll have a look later on today. By the way, what are VSTs?
Hi,
I just get a completely black screen in all modes. Other visualisers seem to work OK. Is there any way of completely removing milkdrop and reinstalling?

I just got a new Windows 10 PRO, PC, 8GB RAM 2 SSD's, Quad core Intel Apollo Lake processor only MB Portable v3.3.7094 and a few associated Apps installed..
The only thing apart from the Milkdrop blank screen is a message about DirectX 9 out of date, but I'm running DirectX 12.
After clicking OK on that, a loud buzzing is heard for about 6 seconds then MB crashes./ closes.
Everything runs smoother, and faster, than old PC, graphics on big TV with MB txt and Theatre Mode, very nice, the only thing lacking is the Milkdrop visuals...
I really hope it's something that can be fixed  :-[
Last Edit: June 08, 2019, 08:16:50 PM by Freddy Barker

redwing

  • Guest
The only thing apart from the Milkdrop blank screen is a message about DirectX 9 out of date, but I'm running DirectX 12.

It requires DirectX 9 files. You need to run DirectX End-User Runtime Web Installer from the first post link.

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
The only thing apart from the Milkdrop blank screen is a message about DirectX 9 out of date, but I'm running DirectX 12.

It requires DirectX 9 files. You need to run DirectX End-User Runtime Web Installer from the first post link.

Very much obliged for your prompt response..
Freddy
Last Edit: June 09, 2019, 09:46:13 AM by Freddy Barker

sveakul

  • Hero Member
  • *****
  • Posts: 1219
Just FYI, I've noticed that some media players that require DirectX9 (MPC-HC, MPC-BE) get around the need to do a system install of the Microsoft redist by just inserting two files from that package into the app's folder--D3DX9_43.dll and D3DCompiler_47.dll.

Folks that use Milkdrop (I do not), could therefore try putting those same two files into MusicBee's "Plugins" folder, if they are averse to running the Microsoft redist web installer, and see if that's a solution.

As far as getting the two files mentioned, people who already have MPC-HC or MPC-BE can just copy them out of those app's folder, which I think is safer than trying to find them on a "DLL Downloads" site.

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
I actually installed Winamp 5.8 last week to see If I could figure out a fix - I could not!!
http://www.winamp.com - However it may be useful for adjusting some settings, transitions or presets.

Finally got Milkdrop running nicely with MB on new PC, thanks to input from @Reddwing and @sveakul.
Do you have these files under \Windows\System32 folder?
"Mildrop2 requires d3dx9_31.dll to be present Fullscreen video OSD requires d3dx9_42.dll to be present."
(http://forums.winamp.com/showthread.php?t=316508)

Not found in my '\Windows\System32' folder, but found these 'D3DX9_43.dll' and 'D3DCompiler_47.dll' here...
https://github.com/clsid2/mpc-hc/releases/download/1.8.6/MPC-HC.1.8.6.x86.zip
And simply moved them to the location mentioned in '@sveakul's post...
Just FYI, I've noticed that some media players that require DirectX9 (MPC-HC, MPC-BE) get around the need to do a system install of the Microsoft redist by just inserting two files from that package into the app's folder--D3DX9_43.dll and D3DCompiler_47.dll.
Folks that use Milkdrop could therefore try putting those same two files into MusicBee's "Plugins" folder, if they are averse to running the Microsoft redist web installer, and see if that's a solution.

It maybe worth adding them to the Mildrop visualiser zip??
Download this link for the visualiser zip file:
http://www.mediafire.com/?7px9a0v015avdyf

And finally, I moved the 'milk.ini' file as suggested in this post by @Redwing...
I did some tests, and probably this would do just for configuring the Transitions tab settings in the screenshot without installing Winamp.

1. Create a sub-folder "Plugins" under your MusicBee\Plugins folder either with normal or portable installation.
2. Save the following text into "milk2.ini" using Notepad and place it under MusicBee\Plugins\Plugins folder you created above.

Code
[settings]
nMainWndTop=53
nMainWndLeft=241
nMainWndRight=1361
nMainWndBottom=840
avs_wx=64
avs_wy=64
avs_ww=256
avs_wh=256
bPresetLockOnAtStartup=0

fTimeBetweenPresets=16.000000
fTimeBetweenPresetsRand=10.000000
fBlendTimeAuto=2.700000
fBlendTimeUser=1.700000
bHardCutsDisabled=1
fHardCutLoudnessThresh=2.450000
fHardCutHalflife=60.000000

Whenever the visualization window size in MB changes, the top-half part of this file gets updated automatically. You can adjust the settings in the bottom-half, consulting the screenshot. Those values are Winamp default values. To enable hard cuts, change bHardCutsDisabled value to "0".

Hope all this helps - Regards: Freddy

I'm now thinking that Milkdrop is running smoother than ever with the older DX9 files than with the latest DX12, could be Milkdrop was created at the time of DX9 or is it that my euphoria at getting Milkdrop running is having a placebo effect?

Regards: Freddy

redwing

  • Guest
When you ran the DirectX End-User Runtime Web Installer, didn't it put the two files, along with others, into Windows\System32 folder?

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
When you ran the DirectX End-User Runtime Web Installer, didn't it put the two files, along with others, into Windows\System32 folder?

Yes I found lots "DXDX9*.DLL's" and  "D3DCompiler_47.dll"

At the time was not sure which ones to move and where to move them to, but Milkdrop failed until I moved D3DX9_43.dll and D3DCompiler_47.dll to "Musicbee\Plugins" folder...
Freddy

redwing

  • Guest
Maybe you needed to reboot your machine after running the installer.
Can you try this? Move the two files from MB's plugins folder to somewhere else. And reboot your machine and see if Milkdrop works without the two files in the plugins folder.
If it's still not working, instructions will need to be updated.

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
Maybe you needed to reboot your machine after running the installer.
Can you try this? Move the two files from MB's plugins folder to somewhere else. And reboot your machine and see if Milkdrop works without the two files in the plugins folder.
If it's still not working, instructions will need to be updated.

Sorry...lunch break!!

Just to clarify, on the new PC, I have NOT yet run the "directx.exe" from the "DirectX End-User Runtime Web Installer" link in the first Post,

The files "D3DX9_43.dll" and "D3DCompiler_47.dll" already exist in "C:\Windows\System32" folder.

On the new PC, Milkdrop just showed a blank screen and crashed after a few seconds.
I didn't do anything over the weekend, then when I read about ONLY moving "D3DX9_43.dll" and "D3DCompiler_47.dll" to "Musicbee\Plugins", today, and Milkdrop worked ok after a reboot.

In the 2 older laptops, both Win 10 pro, if that makes any difference, "C:\windows\System32" has ONLY has the "D3DX9_43.dll" and NOT "D3DCompiler_47.dll", and they both worked fine with Milkdrop.

I'm sure you can understand that I'm nervous about running the DX now as all working just fine, but more than happy to to REMOVE "D3DX9_43.dll" and "D3DCompiler_47.dll" out of "Musicbee\Plugins" to see what happens...

I'll report back shortly -  Regards: Freddy

Freddy Barker

  • Hero Member
  • *****
  • Posts: 737
  • 🎧 MB 3.4.7443 P
Maybe you needed to reboot your machine after running the installer.
Can you try this? Move the two files from MB's plugins folder to somewhere else. And reboot your machine and see if Milkdrop works without the two files in the plugins folder.
If it's still not working, instructions will need to be updated.

1) Booted new PC, auto-runs to start MB via mb.bat,
    launch a playlist-mixer, music starts, switch to Milkdrop vis
    ALL OK.
    Removed "D3DX9_43.dll" and "D3DCompiler_47.dll" from "Musicbee\Plugins"
    
2) Re-booted new PC, auto-runs to start MB via mb.bat
    launch a playlist-mixer, music starts, switch to Milkdrop vis
    BLANK SCREEN - but NO CRASH
    Had to halt MB via Task Manager!
    Replaced "D3DX9_43.dll" and "D3DCompiler_47.dll" into "Musicbee\Plugins"

3) Re-booted new PC, auto-runs to start MB via mb.bat
    launch a playlist-mixer, music starts, switch to Milkdrop vis
    ALL OK.