Author Topic: How to get random playback.  (Read 5404 times)

richardpolhill

  • Guest
I'm stumped. I cannot get MB (2.4.5404) to play random tracks.

Auto DJ simply refuses to select tracks at random, typically just filling itself with tracks from a single album. I just want a Jukebox style selection of tracks so I can leave it running constantly playing music.

What do I have to do to get that? Here are my Auto DJ settings:
initial list: 15, maintain 5 tracks
source tracks from music library
selection mode: random
gap before same artist can repeat: 5

But if I hit preview I just get 15 tracks from the same album.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34418
post a screenshot of your auto-dj settings panel and someone might better be able to help you

Zak

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 2498
Make sure next to the radio button for Random selection you have selected Select by track and not album:

Bee excellent to each other...

richardpolhill

  • Guest

richardpolhill

  • Guest
post a screenshot of your auto-dj settings panel and someone might better be able to help you

I can't find a way to insert images in this forum but I have listed all the settings above.

richardpolhill

  • Guest
Make sure next to the radio button for Random selection you have selected Select by track and not album:



I don't recognize that dialog.

Pingaware

  • Sr. Member
  • ****
  • Posts: 1111
Click on Auto-DJ in the playlist panel to view that dialogue.

Instructions on posting a screenshot are here.
Bold words in my posts are links unless expressly stated otherwise.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34418
that specific feature was added to v2.5 for auto-playlists
for v2.4, whether the auto-dj is shuffled by track or album depends on the shuffle settings in the Preferences/Now Playing settings tab

richardpolhill

  • Guest
that specific feature was added to v2.5 for auto-playlists
for v2.4, whether the auto-dj is shuffled by track or album depends on the shuffle settings in the Preferences/Now Playing settings tab

I only have 2.4.5404

In Preferences > Now Playing > shuffle settings I have “random” selected and “group by album” unticked.

richardpolhill

  • Guest
Thanks Pingaware




Note the Preview showing all tracks from the same album.

Rich

richardpolhill

  • Guest
Nothing? I've upgraded to 2.5 but it still exhibits the same non-random Auto DJ:


Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3840
  • MB Version: 3.6.8878 P
You've got a 'Custom Filter' turned on, but haven't posted a shot of those settings.
A look at those would be great.
It might be where the problem lies.
MusicBee and my library - Making bee-utiful music together