Author Topic: CD Ripping: Error: Not all tracks successfully verified - you can encode...  (Read 6152 times)

Mulgore

  • Guest
Hello everyone,
I'm new to MusicBee and have to say so far I love the program however I've run into a consistent issues with auto ripping CDs within the framework of the program. So far I've been able to download 5 CDs successfully (in a row) but I've come across the following error message

Error #1
Information
<!> Not all tracks successfully verified - you can encode the failed tracks by clicking the "Encode Selected" button

However after reading this error message I check the obvious by selecting all the songs I wanted from the album and trying to select "Encode Selected" however it is completely grayed out no matter how many song I do or do not check. In addition to this the status of the songs are all;

Error #2
Status
       failed: cannot access a disposed object

Not sure what these errors are or how to fix them. I've tried everything I could think of by selecting and selecting different settings until I came across a fix; this is to include renaming the output file name. Any suggestions on the matter would be much appreciated. Thank you!

whismerhill

  • Jr. Member
  • **
  • Posts: 66
2 things:
-1 I don't know why it's grayed out. try to restart the software or your whole computer ?
-2 I doubt if it failed once, it will work just by retrying
music bee seems to be pretty thorough when using secure ripping. (it retries on its own)


whismerhill

  • Jr. Member
  • **
  • Posts: 66
I managed to have one occurrence to have the "encode selected" button  greyed out

here's how it happened :
-rip CD
-verify fail 1 song 0.5% error
-encode
-rename said file to something else in windows explorer (change extension for example, or delete the file)
-file still present in Inbox library in musicbee
-restart "rip CD" interface
-select the proper track (that failed before)
-press Start
-when it fails again with say for example 0.3% (so you'd like to keep this one instead of the previous one), you should have the choice to encode selected

that is when it's greyed out, probably because it's still present in library but not as a file (which prevents it from suggestion the overwrite of the previous file)

so as a result you can't encode at that moment

To get back on track, you have to close ripCD interface
delete the library entry corresponding to the file
and start over the ripping of that particular file (with unfortunately a random result as the number of errors goes probably)

CONCLUSION:
the problem arised for me when you try to rip the same file several times over keeping backups trying to get a better result

Mulgore

  • Guest
For those who are having a similar issue this is what solved my issue in multiple instances.

Instance #1
ALT+CTRL+DEL > Task Manager > End Process - for Music Bee
Launch Music Bee

Instance #2
Restart computer

NOTE: Sometimes it might require multiple restarts if a specific CD/DVD is persistent with errors. Eventually I was able to download 75% of my collection to date using this method.

-Mulgore

Mulgore

  • Guest
Sorry for the late response back.

I followed this in addition to restating the program and computer multipul times to successfully download the CD/DVD I was having an issue with. Thanks for the help!  ;D

-Mulgore

I managed to have one occurrence to have the "encode selected" button  greyed out

here's how it happened :
-rip CD
-verify fail 1 song 0.5% error
-encode
-rename said file to something else in windows explorer (change extension for example, or delete the file)
-file still present in Inbox library in musicbee
-restart "rip CD" interface
-select the proper track (that failed before)
-press Start
-when it fails again with say for example 0.3% (so you'd like to keep this one instead of the previous one), you should have the choice to encode selected

that is when it's greyed out, probably because it's still present in library but not as a file (which prevents it from suggestion the overwrite of the previous file)

so as a result you can't encode at that moment

To get back on track, you have to close ripCD interface
delete the library entry corresponding to the file
and start over the ripping of that particular file (with unfortunately a random result as the number of errors goes probably)

CONCLUSION:
the problem arised for me when you try to rip the same file several times over keeping backups trying to get a better result

whismerhill

  • Jr. Member
  • **
  • Posts: 66
I think I found the way to replicate the issue at will

1st get a CD you're having trouble ripping
rip it once then on the tracks that "failed"
 select "encode selected"

so far it works
get a 2nd CD (or the same) with again ripping troubles
rip it,
tracks fail
"encode selected" is grayed out


so basically the work around is : every single time you use the function "encode selected" you need to restart music bee or else the next time it'll stay grayed out.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34257
i have made a change that should address the issue as described (not tested)
http://musicbee.niblseed.com/V2_5/MusicBee_Exe_Patched.zip

unzip and replace the existing musicbee application files

whismerhill

  • Jr. Member
  • **
  • Posts: 66
This new executable seems to fix the issue, so thanks a lot. No need to restart musicbee anymore yeah !

though I'm not sure if it's related or not so maybe I should make a new post I'm not sure.
Anyway, I saw something new which I'm not sure how to repeat yet.
It seems like sometimes the cd ripping skips the "encode selected" step & go directly to "volume analysis"

1 - the cd ripping will do its thing.
2 - At the end it will say : "volume analysis failed"
2.5 - and indeed if you check in explorer a specific track was not encoded
3 - so I restart with just that one selected, it works fine but presents the "encode selected" option (which is fine)

so I believe what happens is that volume analysis happens and skips the "encode selected" step for some reason. Each time only 1 track was concerned.

Reason I posted this here is because I'm not sure if it's related to the new executable or not.