Author Topic: GUI changes for v3.0  (Read 1107397 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33600
When auto-calculate album rating is enabled in Tags (1), Albums view does not update the album rating immediately, requiring refresh. In Album & Tracks view it's working fine.
how did you apply the track rating eg. click on the player or track info panel, hotkey, tag editor, click in expanded panel etc

mozpri

  • Newbie
  • *
  • Posts: 3
i wont change the auto-scrolling behavior for v3.0 but i have corrected the bug where it shows the playing track at the bottom - it should be shown at the top

This is much better. Thanks.

redwing

  • Guest
When auto-calculate album rating is enabled in Tags (1), Albums view does not update the album rating immediately, requiring refresh. In Album & Tracks view it's working fine.
how did you apply the track rating eg. click on the player or track info panel, hotkey, tag editor, click in expanded panel etc

All of those require refreshing except tag editor.
Last Edit: April 15, 2016, 12:37:44 PM by redwing

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33600
All of those require refreshing except tag editor.
thats very strange then because this functionality has been tested quite a bit a few months back. I will try and check tomorrow

redwing

  • Guest
Click on a track in the main panel and then click on a library filter. You will see focus has not moved to Music node, and if you keep clicking on other filters, random tracks in the main panel get highlighted instead of Music node in the left navigator. v2.5 is working properly.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33600
When auto-calculate album rating is enabled in Tags (1), Albums view does not update the album rating immediately, requiring refresh. In Album & Tracks view it's working fine.
how did you apply the track rating eg. click on the player or track info panel, hotkey, tag editor, click in expanded panel etc

All of those require refreshing except tag editor.
i just did a quick test and all is fine for me - expanded panel, main panel and track info panel all update with the new album rating if the calculated value changes by half a star or more. Given i already have spent quite a bit of time in the past on this for another user where the issue was resolved, i am reluctant to spend more time on this unless you are able shed any more light on it.

edit:
if you send me your settings file i will have another look in case its something obscure
Last Edit: April 15, 2016, 05:50:34 PM by Steven

hiccup

  • Hero Member
  • *****
  • Posts: 6561
When you double-click on a song to play in track details view, and then double-click another song, the speaker icon stays located at the former playing track(s):
(Rostropovich is actually playing here)



Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33600
When you double-click on a song to play in track details view, and then double-click another song, the speaker icon stays located at the former playing track(s):
(Rostropovich is actually playing here)
as i am sure you would appreciate, if that was something that ordinarily happened it would have long ago been reported and fixed. So for now i am putting this down to "something about your machine" but if others report the same or you are able to provide a specific set of steps then i will investigate further
Last Edit: April 15, 2016, 06:13:48 PM by Steven

redwing

  • Guest
i just did a quick test and all is fine for me - expanded panel, main panel and track info panel all update with the new album rating if the calculated value changes by half a star or more. Given i already have spent quite a bit of time in the past on this for another user where the issue was resolved, i am reluctant to spend more time on this unless you are able shed any more light on it.

edit:
if you send me your settings file i will have another look in case its something obscure

With a fresh installation I can reproduce the behavior.

hiccup

  • Hero Member
  • *****
  • Posts: 6561
When you double-click on a song to play in track details view, and then double-click another song, the speaker icon stays located at the former playing track(s):
(Rostropovich is actually playing here)
as i am sure you would appreciate, if that was something that ordinarily happened it would have long ago been reported and fixed. So for now i am putting this down to "something about your machine" but if others report the same or you are able to provide a specific set of steps then i will investigate further

No problem.

Of course I can't have any reliable notion about other users noticing this or making the effort to report it.
For what it is worth, I have also been noticing some refreshing problem/display corruption at the right side of the 'comments' pane for a long time now. (but thought it too unimportant to mention it before)
I am doing it now since it might be related to the refreshing issue with the playing icon and in case other users have some issues there too.


ankor

  • Jr. Member
  • **
  • Posts: 106
When you double-click on a song to play in track details view, and then double-click another song, the speaker icon stays located at the former playing track(s):
(Rostropovich is actually playing here)
as i am sure you would appreciate, if that was something that ordinarily happened it would have long ago been reported and fixed. So for now i am putting this down to "something about your machine" but if others report the same or you are able to provide a specific set of steps then i will investigate further

No problem.

Of course I can't have any reliable notion about other users noticing this or making the effort to report it.
v3.0.5946

I thought I'd try this. The speaker icon seems to switch as expected when I double-click on a track and then click to switch to the next track.  I have Prefs | Now Playing | Playing Tracks List | when tracks are playing = Queue Next and so the current playing track continues to play when I double-click another track.

I did notice something. If I change settings to Prefs | Now Playing | Playing Tracks List | if playback is stopped = Play Now, and I double-click a track while nothing is playing, nothing starts to play.  Seems like "Play Now" isn't taking effect when nothing is playing and I double-click a track.

I don't think this helps hiccup but....

hiccup

  • Hero Member
  • *****
  • Posts: 6561
When you double-click on a song to play in track details view, and then double-click another song, the speaker icon stays located at the former playing track(s):
(Rostropovich is actually playing here)

b.t.w., just in case others experience this too and it is to be addressed, I just noticed I have this happening in the Playing Tracks panel too.


hiccup

  • Hero Member
  • *****
  • Posts: 6561
When you want to scroll through the custom tags in that panel, the scrolling goes very slowly.
In my opinion it would be better if it jumped at least a whole custom tag line per scroll-wheel click.
Using the scroll arrow buttons is even more slow and practically unusable.

Also when you scroll somewhere in the yellow area, instead of the panel scrolling, a drop down table opens immediately.
It would be nice if that would only happen after you had first selected a field there.

The same goes for the tag editor panel when docked at the bottom of the main panel.

The docked tag panel doesn't respond to mouse scroll as I would expect.
The only area that responds to mouse-scroll well is the green area. The red areas do not respond at all, and in the yellow area drop down menu's pop-up immediately without being selected first.
Also the scroll buttons are terribly slow in their action.
Please ignore all this if I am the only one experiencing this.

Last Edit: April 15, 2016, 10:04:33 PM by hiccup

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33600
@hiccup, for the double play icon can you confirm you have only just started using v3 for playback and secondly, if you minimise and restore MB that the invalid icon is gone

hiccup

  • Hero Member
  • *****
  • Posts: 6561
@hiccup, for the double play icon can you confirm you have only just started using v3 for playback and secondly, if you minimise and restore MB that the invalid icon is gone

No, I have been using v3 from the beginning, but the first months only very selectively trying out specific aspects of it.
For a couple of months now I'm using v3 exclusively.

This is what it looks like:
(First I play the first three tracks from the Track Details panel, after that, the same but from the Now Playing panel.)

http://i.imgur.com/UdLspDP.gifv