Author Topic: GUI changes for v3.0  (Read 1247286 times)

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
When configuring the Album & Tracks view for the Playing Tracks List, the contrast settings aren't functional. Nor are the seetings at the bottom of the page:
not all of the settings are applicable for when the album and tracks layout is used in the playing tracks panel because of the space constraints. I wont make any changes to disable the fields that dont apply for v3. The contrast settings for the fields that are displayed in the playing tracks panel should work and do work for me. However if you change the settings via the configuration dialog in the main panel then the changes are not immediately updated in the playing tracks panel, so i will look to fix that

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

unzip into the folder MB is installed and run MusicBee.exe (no longer MusicBee3.exe)

redwing

  • Guest
Click on a track in the main panel and then click on a library filter. You will see focus has not moved to Music node, and if you keep clicking on other filters, random tracks in the main panel get highlighted instead of Music node in the left navigator. v2.5 is working properly.
the focus issue is addressed for the next update. The highlighted node in the main panel should be the last active one for the filter in the current musicbee session

Looks like "selected track" issue is more complicated than I thought, and I am now no longer sure what's the correct behavior.

1. For non-filter node like inbox or playlists:
Click on a track in the main panel and then click on the same node (or a node that includes the selected track) in the left navigator. Currently the track gets unselected in the main panel and track info, lyrics, etc. panels show "No selected track" message. But with v2.5 it remained selected under lowlight selector in the main panel and other panels.

2. library filters:
Click on a track in the main panel and then click on the same library filter node (or a filter node that includes the selected track) in the left navigator. Currently the track gets unselected in the main panel, but remains selected in track info, lyrics, etc. panels (this is a bug). But if you switch to playing track and then return to selected track, then those track info etc panels correctly show "No selected track" message. With v2.5 all panels show no track is selected.

3. Another selected track bug:
Click on a track in the main panel and then click on any other node in the left navigator. Likewise #2, the track gets unselected in the main panel, but remains selected in track info, lyrics, etc. panels (this is a bug). But if you switch to playing track and then return to selected track, then those track info etc panels correctly show "No selected track" message.

My opinion is that if selected track is included in a newly selected node, then the selected track should remain. Especially I don't get why the track gets unselected when you click on the same node again. Also make filter nodes and non-filter nodes behave consistently.
Last Edit: April 19, 2016, 04:40:00 PM by redwing

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
Looks like "selected track" issue is more complicated than I thought, and I am now no longer sure what's the correct behavior.

1. For non-filter node like inbox or playlists:
Click on a track in the main panel and then click on the same node (or a node that includes the selected track) in the left navigator. Currently the track gets unselected in the main panel and track info, lyrics, etc. panels show "No selected track" message. But with v2.5 it remained selected under lowlight selector in the main panel and other panels.

2. library filters:
Click on a track in the main panel and then click on the same library filter node (or a filter node that includes the selected track) in the left navigator. Currently the track gets unselected in the main panel, but remains selected in track info, lyrics, etc. panels (this is a bug). But if you switch to playing track and then return to selected track, then those track info etc panels correctly show "No selected track" message. With v2.5 all panels show no track is selected.

3. Another selected track bug:
Click on a track in the main panel and then click on any other node in the left navigator. Likewise #2, the track gets unselected in the main panel, but remains selected in track info, lyrics, etc. panels (this is a bug). But if you switch to playing track and then return to selected track, then those track info etc panels correctly show "No selected track" message.

My opinion is that if selected track is included in a newly selected node, then the selected track should remain. Especially I don't get why the track gets unselected when you click on the same node again. Also make filter nodes and non-filter nodes behave consistently.
1. is an intentional change. For all previous MB versions, clicking on the library node a second time resets all filters and the selected file. In v3 thats done for all nodes
2 & 3, the implemented behaviour is that any panels showing "selected" reflect the last clicked item in the main panel or playing tracks panel. The reason is so the selection doesnt change when you switch tabs or the active node in the left navigator. I appreciate thats debateable behaviour but i think it can be useful.

redwing

  • Guest
2 & 3, the implemented behaviour is that any panels showing "selected" reflect the last clicked item in the main panel or playing tracks panel. The reason is so the selection doesnt change when you switch tabs or the active node in the left navigator.

Well, I don't think that track is actually selected. I often get duped by that "display bug", thinking a track is selected, and run an external tool hotkey. What follows is constant pop-up of the app windows that happens when no track is selected, and the only resolution I can have at that point is to reboot my machine, as someone else had described earlier: http://getmusicbee.com/forum/index.php?topic=17797.0

sleepless

  • Sr. Member
  • ****
  • Posts: 287
I'm getting all sorts of glitches in the playing tracks list (Album & Tracks):


Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
2 & 3, the implemented behaviour is that any panels showing "selected" reflect the last clicked item in the main panel or playing tracks panel. The reason is so the selection doesnt change when you switch tabs or the active node in the left navigator.

Well, I don't think that track is actually selected. I often get duped by that "display bug", thinking a track is selected, and run an external tool hotkey. What follows is constant pop-up of the app windows that happens when no track is selected, and the only resolution I can have at that point is to reboot my machine, as someone else had described earlier: http://getmusicbee.com/forum/index.php?topic=17797.0
i am not quite following you. Firstly are you saying that is no track is selected then MB sends all files to the external tool? I cant check right now but if thats the case then clearly something should be done about that.
Secondly, i think you are saying there is actually a track selected. Again i am only going from memory but i would think MB uses the selected track from the in-focus panel. If no grid panel is in focus then i need to check what the behavior is

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
I'm getting all sorts of glitches in the playing tracks list (Album & Tracks):
it might be the same issue that hiccup had with another of his skins. I suggest you try using the default skin and if it is resolved then he knows now what needs to be done

sleepless

  • Sr. Member
  • ****
  • Posts: 287
I'm a bit confused...are you saying the right main panel should always be visible in these panels, overriding any settings in the Panels Configuration? For me, the only panels that appear for Radio or Podcasts are the right and left sidebars. The right and left main panels are not displayed regardless of the configuration settings. Should this be functional? If not they should probably be disabled/greyed-out.
i am guessing you are probably still running MusicBee3.exe - its now MusicBee.exe

Nope, I'm running MusicBee.exe - 3.0.5952, and it's definitely not working.

sleepless

  • Sr. Member
  • ****
  • Posts: 287
I'm getting all sorts of glitches in the playing tracks list (Album & Tracks):
it might be the same issue that hiccup had with another of his skins. I suggest you try using the default skin and if it is resolved then he knows now what needs to be done

MB3 Default:


redwing

  • Guest
Firstly are you saying that is no track is selected then MB sends all files to the external tool? I cant check right now but if thats the case then clearly something should be done about that.

Yes, that's been always the case.

Secondly, i think you are saying there is actually a track selected.

Only before clicking on a node in left navigator. After that I don't believe what track info etc panel shows as selected track.

sleepless

  • Sr. Member
  • ****
  • Posts: 287
I'm getting all sorts of glitches in the playing tracks list (Album & Tracks):

I should add that it appears the problem happens when selecting an artist where the sub-grouping header is used. Currently I have this header set for disc display, so when I select an artist that has an album with multiple discs, the glitches occur.

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
Nope, I'm running MusicBee.exe - 3.0.5952, and it's definitely not working.
can you send me your settings file

Steven

  • Administrator
  • Sr. Member
  • *****
  • Posts: 34344
@redwing, yes it is the case that MB sends all files if none are selected so i will change that. For my second comment, if no grid panel is in focus then MB uses the main grid panel.