Author Topic: GUI changes for v3.0  (Read 1284943 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
Pulled up Tracks view and got this error message. Also occurs when switching to Artist view.
can you send me a link to your settings file (help/ support/ view settings)

edit:
actually i suspect you have only posted part of the error and its the same as someone elses. Its probably fixed for the next update
Last Edit: March 09, 2016, 09:55:13 PM by Steven

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10722
"Paste artist picture" is not working in music explorer
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
i recall someone requested that years in the A-Z be supported for vertical orientation. Thats done for the next update

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
Edit: Noticed a bug, the link to the profile page only works consistently when in the Album & Stats tab.
thats fixed for the next update although i will probably add a dedicated tab for it

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
http://musicbee.niblseed.com/V3_0/MusicBee3_Patched.zip

unzip into the musicbee application folder and run MusicBee3.exe
- fixes and changes for the items stated as fixed above

ankor

  • Jr. Member
  • **
  • Posts: 106
edit:
actually i suspect you have only posted part of the error and its the same as someone elses. Its probably fixed for the next update
I also thought the error message was too short but I checked before posting it and that was the whole message.  In any event, I've checked using the latest version and I'm not able to reproduce the error (which was easy for me to reproduce before).  thanks

redwing

  • Guest
Track Info panel works worse. It can't find any artists for multi-artist tracks:

Confirm now it finds first artist for multi-artist tracks.

i recall someone requested that years in the A-Z be supported for vertical orientation. Thats done for the next update

Thanks for supporting this! Very convenient and looks much better than I expected!

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10722
Even though Auto DJ is shown in the navigator, it is not coming up in shuffle rotation from the player controls.  Is this intended?
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
Even though Auto DJ is shown in the navigator, it is not coming up in shuffle rotation from the player controls.  Is this intended?
its working fine here. The only reason i am aware of would be the skin you are using is a custom bitmap that doesnt have an image for the auto-dj

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10722
its working fine here. The only reason i am aware of would be the skin you are using is a custom bitmap that doesnt have an image for the auto-dj

No, it has an auto dj image.  Maybe it's an issue with the sidebar player?  Here's a GIF: http://imgur.com/kYtDO79
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest patches (3.5/3.6)
(Unzip and overwrite existing program files)

KissCool

  • Full Member
  • ***
  • Posts: 183
Tried to use the Semi-Bold style of the Segoe UI font and I have an issue with columns displaying number (like "Time").
With Regular/Italic/Bold style, everything is well aligned (sems to use the "justified" alignment setting). Eg.: same width for 1:11 and 4:44
With all the new Win 8/8.1/10 styles (Light/Semi-Light/Semi-Bold/Black), numbers are right aligned but don't have the same width.

Rebular vs Semi-Bold (just compare numbers with one or more "1" vs numbers without "1")
   ->   

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
Tried to use the Semi-Bold style of the Segoe UI font and I have an issue with columns displaying number (like "Time").
With Regular/Italic/Bold style, everything is well aligned (sems to use the "justified" alignment setting). Eg.: same width for 1:11 and 4:44
With all the new Win 8/8.1/10 styles (Light/Semi-Light/Semi-Bold/Black), numbers are right aligned but don't have the same width.
i wont be able to help with that as its windows doing the text formating

KissCool

  • Full Member
  • ***
  • Posts: 183
OK.

2 probables bugs (maybe already reported. Sorry if they are):
 - rating a track doesn't update the Album Rating ("store ratings in the music file" unticked, "auto-calculate album rating" ticked). Sometimes Pressing F5 works, but usually, have to restart MB.
 - dunno if it's intended, but we can't expand the right sidebar in Now Playing tab (Theater Mode). Only the header appears (think this one was already reported, not sure)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34429
Unfortunately i made a bad decision to allow the navigator to be placed in the left main panel.
There are some implications with various functionality so i am going to remove support for placing the navigator in that panel ie. it will only be enabled to be docked in the left sidebar.
Anyone who already has the navigator in the left main panel, it will still work but going forward you wont be able to drag the navigator from the left sidebar once its placed there.