Author Topic: OggEnc2?  (Read 5183 times)

Save_The_Lost

  • Newbie
  • *
  • Posts: 2
I noticed that the original "oggenc2.exe" in the codec folder was a really old build (from September of 2008), so I decided to take it upon myself to try and update it from the RareWares builds. However, I don't know if it is a lack of personal knowledge of the command line coding syntax, as I'm trying to keep the original presets given by MusicBee, or what the deal is, but I cannot find a build that actually works successfully when trying to use it. It keeps giving me the "File conversion error" dialog every time I try to encode with a different build.

Can anyone help me find the build that actually works properly and still creates a smaller file size than a comparable MP3? The website is right here. http://www.rarewares.org/ogg-oggenc.php

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33482
i found the same and thats why i havent updated it. Mayve the syntax for accepting input from stdin has changed but i dont have time to investigate ir

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 3777
  • MB Version: 3.5.8367 P
I've been using the 2012 Lancer Builds (specifically the base SSE3 Optimized) with no problem.
I haven't tried the aoTuVb6.03 2014 build as the file size is so much smaller, that I thought it might not be compiled with all needed decoders.

EDIT:
oops.  originally left the 3 out of SSE3  ::)
Last Edit: October 13, 2014, 12:14:36 PM by Bee-liever
MusicBee and my library - Making bee-utiful music together

OrB

  • Guest
-q 6 - -o [outputfile]
seems to work in a first test with the Oggenc2.87 using libVorbis v1.3.4 Generic (356kB)(2014)
-q between -2 (low) and 10 (high)
but it looks like -p is not valid in this version

Zak

  • Member
  • Hero Member
  • *****
  • Posts: 2216
but it looks like -p is not valid in this version
Yep, this. The padding option was removed a few years ago as briefly described here:

http://www.hydrogenaud.io/forums/index.php?showtopic=90933

Musicbee includes this in the OGG parameters by default which is why it fails if you replace the oggenc2 executable file with a newer build. It looks like oggenc based on libVorbis (the first one on the RareWares site) fails completely whereas the aoTuVb builds will just ignore it and carry on.

So either:

* Use one of the aoTuVb builds instead (which should also convert faster if you get the one optimised for your CPU), or
* Remove the -p flag from your OGG command line
Bee excellent to each other...