Author Topic: HELP pls! musicbee search randomly groups single tunes (without an album tag)  (Read 2082 times)


  • Guest
My problem is best described through an example.
>> Lets say I search my library for the term 'freedom' to see all songs and albums with that key word.
My search results are displayed as an artwork grid.
The first search result in the top left corner of the grid is given as Unknown Album, and here comes the problem: It consists of randomly selected tracks of which >>none contain the word 'freedom'<< (not even part of the word). To make things worse, Musicbee displays an (in my eyes random) album artist for this collection of singles, even though there is dozens of artists in this Unknown Album and none have the album artist tag.

>>What I am looking for:
- Correct search results (clearly, none of the songs in that random collection has anything to do with my search key, I double checked some of the file names and tags to make sure)
- Musicbee should ignore the 'album artist' field for this random collection of songs, since its across the board and none of the songs are related.

Side notes:
- I use a 3 column browser Genre\Artist\Album. For my example, I do not select anything there and roll with 'All (xx items)'.
- The problem only occurs when I display my library items by their embedded artwork, not when I use the 'Album and Tracks' view.
- Sorting/Grouping preferences: Sorting - everything empty. Grouping: Ticked 'the following fields define an album', first drop down box empty, second 'Album name'. 'Detect iTunes compilations and treat as Album artist' ticked.

old TL;DR: Please bear with me, the problem is hard to describe, and I tried to solve it myself for hours to no avail. I can provide you with screenshots and a copy of my settings if u wish. I would really appreciate if you took the time to help me. Thank you.

NEW TL;DR: Please read my second post. I am looking for a way to organize my single tunes in my library according to this pattern
>> group single tunes by artist, then within those groups songs should be listed in alphabetical order
This should be the case for Albums and Tracks and the Artwork view.
Last Edit: October 15, 2014, 05:35:48 PM by mideya


  • Guest
The problem persists also in 'Albums and Tracks'. 273 single tunes that fit no description are thrown together in an Unknown Album (again with a random artist in the description) in non-alphabetical order right at the top of my 'Albums and Tracks' view.

I believe it all boils down to this:

I need to tell Musicbee to

>> group single tunes by artist, then within those artist groups songs should be listed in alphabetical order
This should be the case for Albums and Tracks and the Artwork view.

I have no background in IT, and do not know how to create a virtual tag for this. Hence I chose Musicbee over something like, say, foobar. Can anyone help me with this?


  • Sr. Member
  • ****
  • Posts: 1111
As far as I can tell, you can achieve what you want by doing this. Click the button at the top right of the main panel, above the scroll bar and below the column browser. From there, go to Sort By>Define Custom Sorting. In that menu, go to the grouping section and change "The following fields..." bit to 1) Artist, 2) Album Name.

Be warned - if you have multiple tracks from one artist with no defined album tag, this will still produce strange things. This is not MB's fault - it's designed (like all music players) for properly tagged files, and it's doing the best it can with ones missing the basic tags (namely track number, artist, album and album artist).

As for the searching problem, MB searches all fields - it's entirely possible that a comment field, or even one not visible in the main tag editor, contains the search term. To check, open the offending file in the tag editor (floating window) then click on the Tag Inspector button. That shows you all the tags on the file, and you can delete any you don't want.

Finally, it's possible you've got a setting enabled that's giving you problems in artwork view when searching. Go to the artwork tab, click on the same button as described in the first paragraph, and go to Search Results. If 'Always Show Entire Album' is ticked, untick it.
Bold words in my posts are links unless expressly stated otherwise.