Author Topic: playing two or more bundled tracks in sequence - even in random mode  (Read 15317 times)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
the auto-dj should work.
What happens if you enable shuffle mode and double click the first of the sequenced tracks?
and can you post a screenshot of your auto-dj settings

Rachmaninoff

  • Jr. Member
  • **
  • Posts: 24
Hi Steven,

how can I send a screenshot to you ? - pls let me know ...

I have an example list of 19 tracks (two Joe Jackson albums) - the first two (track 1,2) are ticked as a sequence - I chose random mode - I start the list by playing track 1 from the first album and I am awaiting that the next one being played will be track 2 - but it is ... track 5 from the second album.


Rachmaninoff

  • Jr. Member
  • **
  • Posts: 24
Yes, Redwing - the list contains both tracks.
But even if not, the combination of 2 (or more) tracks in sequence should work when only one of the associated tracks is in the current play list.

redwing

  • Guest
Yes, Redwing - the list contains both tracks.

Then it should play them in sequence even in shuffle mode. I tested several times and it's working fine for me. Make sure you're using the latest version: http://musicbee.niblseed.com/V2_5/MusicBee_Exe_Patched.zip

But even if not, the combination of 2 (or more) tracks in sequence should work when only one of the associated tracks is in the current play list.

What's currently implemented is a little different from what's requested. For instance, it doesn't play from #1 thru #3 when #2 or #3 was chosen to play. Also only tracks in the list get played.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
For instance, it doesn't play from #1 thru #3 when #2 or #3 was chosen to play. Also only tracks in the list get played.
thats intentional - when MB randomly chooses the next track it will always start from the first in the sequence ie. its only when you initiate playback that the one selected starts

@Rachmaninoff, i dont have time to look right now but i expect you dont have standard random shuffle enabled nor in the auto-dj eg. you might have different artist as the random mode. Its quite possible the sequencing logic is not implemented for that

redwing

  • Guest
For instance, it doesn't play from #1 thru #3 when #2 or #3 was chosen to play. Also only tracks in the list get played.
thats intentional - when MB randomly chooses the next track it will always start from the first in the sequence ie. its only when you initiate playback that the one selected starts

I understand, but I think that can be overridden if it has to by some special handling for tracks in sequence. But probably it's some work because it would then have to look at entire library, not just tracks in the source. I didn't keep insisting on that as I wasn't sure if that feature is worth of that time and effort. Rather the user could just provide all sequenced tracks to the source.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
i checked the other random mode settings - if you have "Recently Added Prefered" or "Higher Rated Prefered" as the shuffle mode then it wont work.
This should fix that - unzip and replace the existing musicbee application files
http://musicbee.niblseed.com/V2_5/MusicBee_Exe_Patched.zip

Rachmaninoff

  • Jr. Member
  • **
  • Posts: 24
Steven, congratulations, it really works now.

The problem was not any "abnormal" random mode, there are some constraints within my AutoDJ and with the tagging procedure, which might be evident, but of course you've got to think of that first.

a) the most important one: Auto DJ restiction "gap before the same artist can repeat" MUST BE 0 - it was 20 when I tested it the first time ...

b) you have to tick both tracks with the new flag - track 1 AND track 2 - not only track 1 (which I thought it is enough information ...)

c) if you want to do this, you can`t edit track 1 first and set your flag to YES, then save it, and the track 2 the same way - it doesn't work
>> you have to mark both tracks together, edit both, and chose "YES" for "keep tracks in sequence..."

But if you are playing those rules - it works perfectly - thx a lot   :)

Rachmaninoff
 

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32048
points b & c are definitely needed. I dont think the artist gap would matter so are you sure about that?

Rachmaninoff

  • Jr. Member
  • **
  • Posts: 24
Yes, definitively sure - if the artist gap is set to 1 (or higher), all associated tracks never will come together - if you switch back to 0, it works again.
But finally this is consequent in its logic - it's only to keep this in mind, when you want to listen to combined tracks. 

Rachmaninoff

Caedendi

  • Newbie
  • *
  • Posts: 9
I've actually been wanting this feature for a while too, so Rachmaninoff, thx a lot for requesting this, and Steven, thanks a way lot more for implementing this^.^