Author Topic: Can't get Rainmeter music players to work with Musicbee  (Read 11895 times)

imagiraffe123

  • Guest
Apparently, this issue was fixed back in 2011 or so, but right now, I can't seem to get Musicbee to cooperate with Rainmeter music players. I've got it to work with Foobar, winamp, and media monkey, but I'd rather be able to use Musicbee.

I've tried both CAD, and Musicbee as the media player names.

If anyone could help me with this, I'd greatly appreciate it.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33114
you need to enable the CAD plugin in the Plugin preferences. If that doesnt work then one the Rainmeter developers quite often visits the forum and might be able to help

imagiraffe123

  • Guest
Went to Preferences > Plugins.

Tried to enable CD Art Display. Gives me an error: "CD Art Display does not appear to be installed on this machine."

Weird. Do you think I'd be able to copy the plugin from foobar2000 or something? I can't find a download link for the plugin online.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33114
you dont need CAD itself for the purpose of using rainmeter - enabling the plugin activates the API interface that rainmeter uses


Harvey Honeycomb

  • Guest
I'm having trouble with rainmeter as well. Enabled CAD in plugins but the music skin still isn't displaying track info. (The play/skip track controls seem to work however.) Did something change from 2.3 to 2.4 that would affect this? Been searching the forums and this seems like the most recent topic concerning rainmeter issues, but if I should post this elsewhere please let me know.

redwing

  • Guest
I'm having trouble with rainmeter as well. Enabled CAD in plugins but the music skin still isn't displaying track info. (The play/skip track controls seem to work however.) Did something change from 2.3 to 2.4 that would affect this? Been searching the forums and this seems like the most recent topic concerning rainmeter issues, but if I should post this elsewhere please let me know.

Have a look: http://getmusicbee.com/forum/index.php?topic=10914.msg66398#msg66398

It's working fine with the latest version of MB & Rainmeter.

Harvey Honeycomb

  • Guest
Thank you for your reply. Unfortunately your advice hasn't had an effect, I think because I'm not using the Enigma skin. This is the skin pack I'm currently using.

http://fiftyniner.deviantart.com/art/Desktop-493372796

Strangely enough, changing PlayerName=CAD and PlayerName=MusicBee in the UserSettings.ini both seem to attach the play button within the music skin to MusicBee but it doesn't display track information. I'll ask the author of the skin for suggestions.

Thanks again.

redwing

  • Guest
Tried that skin, and it's working fine displaying track info.
Only edited player name to CAD in UserSettings.ini file.

Code
MusicPlayer=CAD

Harvey Honeycomb

  • Guest
Yup, got it working myself too. Just had to redownload the skin, guess it didn't completely take the first time.