Author Topic: Tagging Multiple Artists with Picard  (Read 2844 times)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 2196
Thanks Chartal,

I was using an even more recent dev7 version that psychoadept gave a link for, but it wouldn't work with my album.
I tried many times, cleaning all tags, different releases etc.
It seems to be a feature that is too dependent on several factors to 'just always work'.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6681
This is what I get when I load that album (same release, same version of Picard):




Here are my relevant settings:





If none of that helps, you might check your picard error log.
Last Edit: January 12, 2017, 05:00:06 AM by psychoadept
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.1)
(Unzip and overwrite existing program files)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 2196
If none of that helps, you might check your picard error log.

Using the exact same settings wouldn't improve things.
Then I looked at the error log, and noticed several entries concerning some failed web access (or matching, sorry, I didn't write it down).
I noticed I had some LastFM plugins present, and I had also experimented a bit with the suggested code from MB Wikia.
Then I decided to uninstall Picard, remove all remaining concerning folders and re-install Picard.

And now it all seems to work.
The only thing that I don't understand yet, is that even though I stripped the Gaucho album from all it's tags, Picard will match it everytime with a certain DTS release, which happens to be about the only one that has no performers mentioned at all.
But at least now I can hand pick another release that has that info, and it's loaded just fine then.


A question about your setting:
You have set encoding to UTF-16
I would be inclined to use UTF-8
Is there a specific reason you have set UTF-16?

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6681
A question about your setting:
You have set encoding to UTF-16
I would be inclined to use UTF-8
Is there a specific reason you have set UTF-16?

I think I just left that at default.  It's never caused any problems.

Glad you got things working!
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.1)
(Unzip and overwrite existing program files)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 2196
Glad you got things working!

Yeah, this is really great.
I am kind of 'into' musicians, so this has always been important to me. And it frustrated me for a long time (many years by now) that I had to enter that manually for albums and artists where it was important to me.
The bad news of course is that this will require/force me to revise my practices and tagging schemes concerning this.

A next question comes to mind:

I came across this plugin for Picard:



Looking at it, I think I agree with the result of what it does.
Your opinion?


P.S.
This might all be swirling a bit off-topic for this Tips & Tricks topic?
Do feel free to split, merge, correct me if you think so.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 6681
Yes, that's the plugin I was recommending.

I figure all this discussion can help others, too...
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.1)
(Unzip and overwrite existing program files)

hiccup

  • Member
  • Hero Member
  • *****
  • Posts: 2196
A question about your setting:
You have set encoding to UTF-16
I would be inclined to use UTF-8
Is there a specific reason you have set UTF-16?
I think I just left that at default.  It's never caused any problems.

Ok, probably not an issue then at all. Just asking since (also Picard themselves say that) UTF-8 is 'default' for ID3v2.4.
https://picard.musicbrainz.org/docs/options/

But when you set Picard to use 2.4, it doesn't switch to UTF-8 automatically.
Probably a not-very-important oversight.