Author Topic: MusicBee keeps moving my video files  (Read 4393 times)

Hypolitus

  • Jr. Member
  • **
  • Posts: 21
I've upgraded to version 2.3.5173 from v2.1.? and now MusicBee keeps moving WMV files that are in my music folders into an 'Unknown Album Artist' folder. I don't want it to do this - I want it to leave all video files where I put them. As far as I can see, I've got it configured to ignore video files (the 'include video files' option in the Rescan/Add Files dialog is deselected), but it won't leave them alone. Am I missing something?

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10675
Check your auto-organize settings in Library Preferences: http://musicbee.wikia.com/wiki/Library_Preferences
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Hypolitus

  • Jr. Member
  • **
  • Posts: 21
I did, but I can't see any way of configuring it to prevent it organising WMV files that are in my music folders. For example, I can't put an exception in based on the Kind of the file being WMV because WMV isn't appearing as an option in the dropdown.

Hypolitus

  • Jr. Member
  • **
  • Posts: 21
I also put an exception in based on the .ext of the file, but that didn't work either.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10675
Are you looking at the Video section of auto-organize?  If you uncheck the "move files to folder" box, it will turn off auto-organize for videos.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Hypolitus

  • Jr. Member
  • **
  • Posts: 21
Yes, that was the first thing I looked at. It isn't making any difference what I do in the video section, because the WMV files are being treated as though they are music files.

It's not a big problem; I'm working around it by tagging up my video files in MusicBee. I'd rather not be doing that, as the tags seem to be a bit fragile (renaming the file in Windows Explorer loses the tags, so I suspect MusicBee is storing externally in the library rather than embedding them in the WMV file), but it's a bit irritating.

Thanks for your suggestions.

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10675
You should report this as a bug, in that case.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 33278
you need to move the files to the Video category in the left navigator - any files in the music library will be organised according to the music template. As to how the files got in the music library node in the first place, it shouldnt happen when adding WMV files using the new version - perhaps with v2.1 there was a bug with that.

Hypolitus

  • Jr. Member
  • **
  • Posts: 21
Ah, mystery solved! The only WMVs I have are bonus tracks on standard (music) albums. When they're downloaded onto to my hard drive, MB picks them up and puts them in the Inbox. Once I've checked that all the tags are okay, I just right-click on the album thumbnail in Artwork view and send the whole thing (including the WMV) to the Music Library. I'll just have to remember to send the videos to the video library separately. Thanks guys.
Last Edit: March 04, 2014, 04:35:21 PM by Hypolitus