Author Topic: Ctrl+C & Ctrl+V  (Read 3849 times)

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
When (and why) did these stop being the hotkeys for Copy and Paste tags?  Whenever I try to assign them, I get a message like 'Ctrl+C is a reserved key and cannot be used'.

When I originally made the wiki page they were still working: http://musicbee.wikia.com/wiki/Hotkey


Edit: Okay, on installing 2.3 portable I see that those hotkeys are still assigned as in the screenshot.  So maybe this should be a bug?  I must have changed them at some point, but I sure would like to be able to change them back.
Last Edit: March 02, 2014, 03:02:37 AM by scampbll
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)


psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
Yeah, wow.  I'd completely forgotten about that post.  Thanks.   :-[  (In my defense, though it was related, that was addressing a different bug...)

I think my backup was made just before that, so when I restored the hotkeys were messed up again.  Sorry for the false alarm.  Still, I think the issue of not being able to change the hotkeys back to their original settings should be addressed (a "reset all" for hotkeys wouldn't be a bad idea, either, but I'd rather be able to do it on specific hotkeys).
Last Edit: March 02, 2014, 03:30:44 AM by scampbll
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

redwing

  • Guest
I think that was raised before.

Steven, of course I can temporary return old command description to user be able yo clear hotkey for it, but I think there is need for universal solution. Maybe its worth to get user opportunity to assign hotkey which is used by inactive (or obsolete) command? Hotkey for inactive command should be cleared in this case.

There should be no unassignable hotkeys beyond the user's control. Currently the only solution is manual editing of the settings file like this.  

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
There should be no unassignable hotkeys beyond the user's control. Currently the only solution is manual editing of the settings file like this.  

Well, the delete hotkeys can't be assigned right now, but yeah, definitely anything in the official hotkey list should be configurable.
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

psychoadept

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 10656
So, I've run into this problem again.  I wanted to change Ctrl+C to the Copy command that includes play count.  Now, not only can I not reassign Ctrl+C to the original copy command, I can't even seem to fix it by messing with the INI file.  Not sure what I'm doing wrong, but please could we have Ctrl+C and Ctrl+V be assignable hotkeys?

Edit: finally fixed it with the ini.
Last Edit: July 03, 2017, 05:20:27 PM by psychoadept
MusicBee Wiki
Use & improve MusicBee's documentation!

Latest beta patch (3.5)
(Unzip and overwrite existing program files)

imminiman

  • Jr. Member
  • **
  • Posts: 60
  • Music is my life, 'cause my life is music.

Edit: finally fixed it with the ini.

Could you please elaborate?
I'm trying to edit the MusicBee3Settings.ini file so that -
Code
  <Key>131139</Key>

replaces the "Key" part in here:

Code
<KeyCommandPair>
  <Key>196673</Key>
  <Command>EditCopyAll</Command>
  <IsGlobal>false</IsGlobal>
 </KeyCommandPair>


But after saving it and reloading MusicBee, It overwrites the file...


Okay I got the copy all hotkey work, but now I can't make the paste one work with ctrl+v.
Last Edit: August 24, 2017, 11:52:59 AM by imminiman

imminiman

  • Jr. Member
  • **
  • Posts: 60
  • Music is my life, 'cause my life is music.
Okay got it to work with ctrl+v as well.

To make ctrl+c work I unassigned the previous hotkey of copy all and left it blank. Closed MusicBee and saved the .ini file again with the Key set to "131139" in the .ini file. Opened up MusicBee once again and it worked.

To get ctrl+v to work for pasting the tags, I set ctrl+shift+v as the hotkey for it, saved and closed MusicBee. Then made sure that the key was set to "131158" in the .ini file. Then I cut and pasted the MusicBee3Settings.ini file to my desktop, then opened up MusicBee once again and It was set to ctrl+v.

I just hope no other setting got lost in the process.