Author Topic: Hard Disk detected as MTP Device  (Read 7600 times)

PureLoneWolf

  • Newbie
  • *
  • Posts: 15
Hi there

This has happened in the last few days (not sure when), but there has been no updates or software installed.

I have a number of internal hard drives in my PC, which is the media hub for our home.  However, MusicBee has decided to pickup the H drive as an mtp device.

Windows (8 Pro 64), however, still sees it as a normal hard disk.  It is causing problems with playing anything from this drive in MusicBee.  It, basically, gives an error about an incorrect audio file.  However, I can load anything in other media players (vlc, xbmc etc) and everything works without issue.

I have rebooted a few times and can't figure this out.  If I disable "Automatically detect MTP devices", it works normally.

Would anyone have any ideas?

Thanks




Last Edit: September 20, 2013, 01:40:23 PM by PureLoneWolf

redwing

  • Guest
No idea why that drive alone was picked up. Do you get any menu like "set as fixed drive" if you right-click on the drive from computer section of MB? If so, that will help.

PureLoneWolf

  • Newbie
  • *
  • Posts: 15
No, I don't get any options.

When I turn off "Auto Detect MTP", the drive is in the Computer Section, but doesn't have any options available for it.  Then, when it is turned on, it is removed from the computer section and is only listed as a device...but that doesn't have options either...at least none that I can see :/

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
the first thing to do would be to upgrade to v2.1 to see if its already addressed. If it does change anything let me know you will run a debug version

Thorbjorn

  • Guest
I have the same issue. One hd is picked up as a media device. I'm using the latest beta.

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 34416
@Thorbjorn, could you run this debug version with MTP devices enabled:
http://www.mediafire.com/?hv8mj15585w3c1c

and then send me the entries at the end of the error log (help/support/view error log)


@PureLoneWolf, you should still upgrade to v2.1 first from the downloads page before running this debug version

Thorbjorn

  • Guest
It's the O drive that's recognised as a media device.

21/09/2013 12:58:57 - C:\,True,Fixed
21/09/2013 12:58:57 - D:\,True,Fixed
21/09/2013 12:58:57 - E:\,True,Fixed
21/09/2013 12:58:57 - F:\,True,Fixed
21/09/2013 12:58:57 - G:\,True,Fixed
21/09/2013 12:58:57 - H:\,True,Fixed
21/09/2013 12:58:57 - I:\,True,Fixed
21/09/2013 12:58:57 - J:\,True,Fixed
21/09/2013 12:58:57 - K:\,True,Fixed
21/09/2013 12:58:57 - L:\,False,CDRom
21/09/2013 12:58:57 - O:\,True,Fixed
21/09/2013 12:58:57 - Y:\,False,Removable
21/09/2013 12:58:57 - Z:\,False,Removable
21/09/2013 12:58:57 - mtp devices:
21/09/2013 12:58:57 - \\?\wpdbusenumroot#umb#2&37c186b&0&storage#volume#_??_usbstor#disk&ven_generic&prod_flash_hs-combo&rev_5.39#26020128b005&1##{6ac27878-a6fa-4155-ba85-f98f491d4f33}
21/09/2013 12:58:57 - storage count=1
21/09/2013 12:58:57 - storage id=Z:\,3
21/09/2013 12:58:57 - \\?\wpdbusenumroot#umb#2&37c186b&0&storage#volume##{6ac27878-a6fa-4155-ba85-f98f491d4f33}
21/09/2013 12:58:57 - storage count=1
21/09/2013 12:58:57 - storage id=O:\,3
21/09/2013 12:58:57 - \\?\wpdbusenumroot#umb#2&37c186b&0&storage#volume#_??_usbstor#disk&ven_generic&prod_flash_hs-cf&rev_5.39#26020128b005&0##{6ac27878-a6fa-4155-ba85-f98f491d4f33}
21/09/2013 12:58:57 - storage count=1
21/09/2013 12:58:57 - storage id=Y:\,3


Thorbjorn

  • Guest
That seems to have fixed the issue. Thanks.
I'll report back if it happens again.

PureLoneWolf

  • Newbie
  • *
  • Posts: 15
Should I go straight to that version or 2.1 first?  Thanks

Thorbjorn

  • Guest
You should probably upgrade to the latest version first

PureLoneWolf

  • Newbie
  • *
  • Posts: 15
Ok - Upgraded to 2.1 Final and the problem was still there.

I applied the 2.2 patch that Steven uploaded and the problem has gone :)

Just testing all my other stuff now to make sure nothing is lost :)

Pandarus

  • Guest
I just want to say Thank you. This pors helped me realise I could turn a network drive into a device and sync to it.

This works for me because I've shared my phone's internal storage and sd card as network drives.

Thank you!