Author Topic: Delete Library  (Read 60944 times)

coolguy31337

  • Guest
After creating a library with File > New > New Library, how do you delete it?

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32736
just delete the directory using windows explorer - i didnt want to put that function in MusicBee

Tigertales

  • Guest
Is it possible to re-set a library?

I'm finding MB wont remove entries I have physically deleted.

Thanks - this software has huge potential if I can learn it easily enough.


----------------
Now playing: Grant Lee Buffalo - SuperSloMotion
via FoxyTunes

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 32736
in Preferences/ Library you can set dead links to be automatically removed

JanW

  • Guest
Sorry for resurecting an old topic, but i'm trying to get help on a similar problem.
Let me explain what i did: By trying to listen to the music found on my desktop pc remotely from my notebook's musicbee, i went ahead and "chose an existing library" and pointed it to the library from my desktop pc's musicbee. Of course that didn't go well, and now i want to remove it from the drop down list at the "file>open library" menu.

Btw, i later realized the best way to achieve my original idea was just creating a new one and selecting the folder from my desktop pc (which is shared over the wlan).

beehive

  • Full Member
  • ***
  • Posts: 203
now i want to remove it from the drop down list at the "file>open library" menu.
To do that delete the folder in windows

JanW

  • Guest
sorry but delete what folder? im not gonna delete my music folder on my desktop pc.
I already tried disconecting from the wlan and restarting musicbee on the notebook, the link to the desktop pc's library file doesnt show up, but it shows up again after connecting to the wlan. So i guess this info got recorded somewhere in musicbee's registry?

beehive

  • Full Member
  • ***
  • Posts: 203
Of course dont delete your music. You could try networking your desktop pc to your notebook and delete the folder that is linked to your pc in musicbee in your notebook. If that folder does not exist anymore then create it, open that library in musicbee, close musicbee, delete the created folder, then see if it is still in your dropdown list. hope it works

lnminente

  • Hero Member
  • *****
  • Posts: 1049
-Turn off your desktop pc or disconnect it from the network
-Press Shift key while starting MB in your notebook, then you will see a menu showing you the libraries used.
-When MB can't access to some library it will show you the option to remove it

JanW

  • Guest
Gracias Inminente, right on the spot.
Thanks !

lnminente

  • Hero Member
  • *****
  • Posts: 1049
You're welcome JanW. I did more research, i leave it for informational purposes:

That info is stored in the appdata folder of musicbee in a file named StartupSettings.ini
Exactly under <KnownLibraryPaths><
For deleting the path to a library we should delete the line with  <string>[Path to the library]</string>

AZMedia

  • Guest
I created a folder and threw in a bunch of music to test the "Bumble" of the Bee. Creating a new library seemed like the logical thing to do. Now I can't get rid of this library.

I deleted the folder and all the music. Restarting the application did nothing.
I checked the box "Remove dead links" under Library preferences. No change after restarting the app, no prompts.
Clicking on music tracks in this library view were dead links. So I deleted all the tracks. No change, no prompts.

Using "shift" key I can see the two libraries, but there is no option to delete a library. I checked the "Always prompt for Library selection". Restarting the application did not cause any prompt.

Now what? How do I delete the library?


Both libraries are still viewable in the upper left selection:



Last Edit: August 24, 2012, 12:51:59 PM by AZMedia

AZMedia

  • Guest
You must first tick the box "View Hidden Files and Folders" in Folder Options of your PC. Now:

Go to Users>Your User Name>AppData>Roaming>MusicBee
Right click on the StartupSettings.ini  and "Rename"
Change the extension from ini to "txt". Now you can open the file.
Go to the line <string>some folder location<string>    Delete this line, then click SAVE using the menu.
Rename the file back to "ini". You are done.!

biz_kid1

  • Guest
Every time I make a string to the change (i.e., I delete all but the ONE I want to show in MB), when I reopen MB, the new one is there but so are the old ones, as if it added (rather than saved over) the .ini file.  I want to be able to just right-click and delete the library I don't want within MB!!!

Becool

  • Guest
Wow, six years after the initial post and the issue still exists?

I have recently installed MB as it was highly recommended to me. I set up the "initial" library for my music collection, and later added a new library für my audio books.
Now I realized it would be easier to have everything in the same library and just move all audio books to the corresponding tab. So I set out and tried to first delete the audio book library and then add the files to the initial one.
Sounds easy enough, but it seems virtually impossible.

OK I understand there is no "delete library" option because, quote, "i didnt want to put that function in MusicBee". Fair enough.

Now I found this thread and tried to follow the instructions via editing the ini file (note: if you have the unwanted library open when exiting MB and THEN edit the ini file, it will NOT disappear. It only worked for me when I selected my main library before closing and editing).

Well this seems to help at first, it really restarted MB with only one library in the menu.
However, now when as a next step I tried to add the audio book folder of my network drive to the main "MusicBee" library via the "Rescan/Add Files" function, it claims that "this folder is already a mapped network drive" and won't let me add it.

I have been trying all kinds of variations on this now and can't get MB to realizeaccept that I just want to delete the stupid library... Shall I just give up? Reinstall and rescan everything (that took hours...)?
Or has anyone found a workaround for this issue that works?

Thanks for any help you might be able to provide.
Cheers
B