Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jafigg

Pages: 1 23
16
Questions / Backup Collection function
« on: October 22, 2023, 05:23:55 PM »
Hi,
To update my musicbee files over my backups (I've two) I tried this feature (mainly to make easier to update modified tags on these backups) on a part of my actual musicbee library over the same part of one of my backup..

Source: Folder/subfolders/etc. with 65.701 files

Let's go... Musicbee start to copy about 18.000 files as I see on screen (files that I suppose different in some ways from those on the backup).
Process ended but the target properties says 65.642 files, which does not match.

I first suppose this comes from files that were no more in Musicbee libray anf that I've not deleted in my backups, but it doesn't make sense, The function is intend to delete and copy files on the target to macth the library so number of files should be the same.

I wonder if I can find a log file to see what happens or why there is this difference.

Thank you
Jafigg

17
Tips and Tricks / Some characters tricks
« on: October 21, 2023, 03:53:45 PM »
In artist tag:
If you've set grouping preference to ignore "The" (or anything else) but, in some cases, want to have an artist listed in T list, like, let say "The Big Bopper" (his complete stage name, which I want in T and not in B), you can insert two half-spaces (2x unicode character U+2009) after "The" instead of an usual space, you can't see the difference but Musicbee listed it at T.
I also set one half-pace before "!" + "?" and one after ";" which is more pleasant to my eyes and match typographic rules.
(got this half-space stuff in another post, but not for that purpose)
Copy the half-space inside parentheses: ( )

In filenames, you can override the forbidden slash and question mark by using "∕" (unicode character U+2215) and "?" (coming from Japanese keyboard layout, there's a little space after, but can't find another way)
Copy this inside parentheses: (∕) (?)

This is for Windows, I don't know for other OS, but I'm sure there's also a way.

It may probably have been posted but if not, hope this can be useful to some...

PS: Sorry for my crappy english (I'm French)

18
i doubt this will be supported in the future as there are complications when using a custom background image

Thanks for answering... I'll stay with my custom blueish and rounded thumbs (I really like them) rather than setting a full background image...
Regards,
Jafigg

19
When using full image background, the option is greyed out



 Can that option be available ? Hope so...

Jafigg

20
Questions / Re: (still) Questions about modify xmlc skin with piggy-back
« on: September 26, 2023, 04:58:12 PM »
Here comes "le casse-pied" (a french expression) again...

and base64 code
Doesn't work..
Search in the <images id="Default"> section without sucess
Did I miss something or is it just not possible?
Those buttons are actual image files that the creator of the skin made and then compiled into an .xmlc skin.
The only way to change those is by creating  an .xmlc skin.

I have two suggestions for you:

   1. Contact the author of the skin and see if he is willing to share the source files with you.  
You can then modify anything you want and compile it into an .xmlc skin yourself.  
  
   2. Take a look at the Chameleon skin.  
It is a skin designed to make it easy to create your own colour-themed skin that will be fully MusicBee compliant in all other aspects.  
You will only need to colour-pick the colours from the original skin and apply them to 'your' Chameleon.  
It should give pretty good results fast without too much effort.
 

Thanks again,
I just download the Chameleon, let see if I'm able to deal with it...

BTW, I try too to apply a custom image background to the left panel using several methods with base64 and the FilterPanel.Default lines... adding, removing etc. What I only see, depending on what line was in or not, is some lighter colour of that panel, but no image. I think I'll give up on this one.

Regards.

21
Questions / (still) Questions about modify xmlc skin with piggy-back
« on: September 26, 2023, 08:39:11 AM »
Hi,
Here comes "le casse-pied" (a french expression) again...

Now that I've achieve the goal with the NoArtwork and Play/Pause images in tracklist (Thanks to Lord Hiccup), I'm looking for that:

I've this:


And I want that:

(This is an homemade image with an editor)

Based on Sample skin colors, I try with:

<element id="PlayerFlat.Control.Default">
 <element id="PlayerFlat.Control.Highlight">
 <element id="PlayerFlat.VolumeIcon">

and base64 code

Doesn't work..

Search in the <images id="Default"> section without sucess

Did I miss something or is it just not possible?

22
Questions / Re: (further) Questions about modify xmlc skin with piggy-back
« on: September 25, 2023, 07:06:56 PM »
I wonder if it's possible to change this play/pause button
Yes, you can create icons for them.
The Sample Skin lists all items that you can create images for.

You will be looking for:

PlayingIcon.Default
PlayingIcon.Highlight
PausedIcon.Default
PausedIcon.Highlight

It works... It's up to me now to deal with images... Thanks again !!!

23
Questions / (further) Questions about modify xmlc skin with piggy-back
« on: September 25, 2023, 12:25:14 PM »
Hi,

Now that I've discovered the base64 trick to change the NoArtwork image through the piggy-back (funny name BTW) skin. I wonder if it's possible to change this play/pause button (just removing the circle):


I browse the forum, search in the Sample skin lines, try to look after a program to edit xmlc files but, well, I'm in a dead-end now and I hope someone here could provide some base64 code for these buttons, and, why not, for buttons on the play bar (play/pause, previous/next) and ability to add a background image of my own to other panels (Artist list on the left and/or tracklist on the right) like you can do in the main panel...

It's a lot to ask, and I'm not even sure if it is possible, and yes, I should consider building a skin of my own, but I think I'm too noob for that. After trying numerous skins, I think for sure now that "Arsenic Atratum.xmlc" by Bee-liever make the hell of the job (except, and maybe just for me, for some very tiny details)..

24
Bug Reports / Re: Bug when using backgroung image
« on: September 24, 2023, 09:19:08 AM »
i did find an issue from your settings from the left side of the Album & Tracks header being set to none. Thats fixed now
https://getmusicbee.com/patches/MusicBee35_Patched.zip
unzip and replace the existing musicbee application files
Works like a charm... You're a genius !

25
You can achieve this by creating a piggy-back skin.
https://getmusicbee.com/forum/index.php?topic=29815.0
Doing some forum searches on 'base64' should explain how to add images to such an xml.

I search for that 'base64' you mentioned and find the trick here:

https://getmusicbee.com/forum/index.php?topic=22889.msg133926#msg133926

Successfull...
Thanks !

26
Hi
I find this <!-- NoArtwork --> line in hiccup's sample skin, but I don't known how to manage that (i.e. a link to an image store on the computer or something else).
I doubt it's possible, but I hope not.

In my case, I'm now using Arsenic Atratum by bee-liever

Thanks...

27
Bug Reports / Re: Bug when using backgroung image
« on: September 23, 2023, 09:47:07 AM »
i cant reproduce the issue. Can you send me a link to your settings file (help/ support/ view settings)
and also describe how you scroll up eg. with a mouse wheel, keyboard etc
Hi,
Here'is the link to the settings (I put 2 files from different skins).

https://www.mediafire.com/file/wfpws1v0ty4gog6/Settings.zip/file

The problem appears when scrolling with both mouse and keyboard, and now I see it's not only for the first album, but others diseappears an
reappers randomly (artwork and tracklist)

28
Bug Reports / Re: Bug when using backgroung image
« on: September 22, 2023, 01:30:58 PM »
I will need more detail, including steps to reproduce the issue

But when I go to the top of the list, this is what I get:
what is "the list" you are referring to? and why did you show a screenshot of the Albums view?
Thanks for answerings,  let's start fresh...
Forget about the album view, it was irrrelevant...

By "Top of the list" I mean when you scroll up to the first album in the view.

Now, this what I get:

Here, I'm on the first album of the artist, without background image:


Now, with the background image set, I still can scroll to the lower part of the first album,


If I want to go up, here is the result (the first album has gone)


Hope this help and I'm sorry if I am not clear enough, my english is not very good.

Regards,
Jafigg

29
Bug Reports / Bug when using backgroung image
« on: September 22, 2023, 08:16:50 AM »
Hi,
I've decided to try background image feature... I make a pic from my wallpaper with a kind of "transparency" effect matching the skin color.
Albums view looks great:


Albums & Tracks view is awesome with that transparency effect


But when I go to the top of the list, this is what I get:


And it don't happen without background image set...

I try with other skins, different image formats (BMP, GIF, PNG, etc.). Still the same.
I also notice that it is OK with the "recent" tab I set with the automatic playlist building

I use the latest MB (3.5.8447 P)


As I often switch to those two views, it's really annoying... Any idea ?

Regards,
Jafigg

30
Questions / Re: Album view sorted by type (LP, EP, Live, etc.)
« on: September 17, 2023, 06:04:16 PM »
Many thanks for your help... But
1 - I'm too lazy to re-organize my folders.
2 - Foe now, I'll stick with common view. Hicupp was right about this kind of splitting views as it's sometimes difficult to point some albums to a specific category.

Well, that was only an example using folder names, but you can use any other tags that already exist in your audio files. The process should be the same.
If you need any further assistance i'll be happy to help
Cheers

Well, I think as people here provide help so... Let's give a try !
Alas, I got this FAILED msg both with my custom tag and the one you provided...

Is there something I don't understand  ?
Regards,

Pages: 1 23