Author Topic: Kandinsky Light  (Read 1298 times)

Fluke

  • Newbie
  • *
  • Posts: 15


Kandinsky Light
Version 1.0.2 | Download Link

A light, minimal theme for Musicbee 3.0 inspired by the old Zune desktop player.
You can find a dark version of the skin here. Let me know about any issues you
find or potential changes you'd like to see!

Install Instructions

Place file in your Musicbee/Skins folder and select it in Musicbee under View > Skins.

_____________________________________________________________________________________

Update Log

Jan. 16, 2017 - Changed border images in file to fix issues relating to title bar. (v 1.0.1)

Jan. 22, 2017 - Changed color of star rating in the main panels to match color in player
controls bar. Changed color of check tick marks in Preferences window to match skin
highlight color. (v 1.0.2)

Last Edit: January 22, 2017, 07:05:04 PM by Fluke

Steven

  • Administrator
  • Hero Member
  • *****
  • Posts: 24202


DarkerthanDreams

  • Newbie
  • *
  • Posts: 6
download link is not working says "this download is currently unavailable" :-\

Havokdan

  • Full Member
  • ***
  • Posts: 180
Thanks, great skin :), I edited just to use the green color here and it was reasonable (I'm not very knowledgeable).

Fluke

  • Newbie
  • *
  • Posts: 15
download link is not working says "this download is currently unavailable" :-\

Mind trying it again? I think it might have been some sort of temporary server error, since it looks to be up now.

DarkerthanDreams

  • Newbie
  • *
  • Posts: 6
download link is not working says "this download is currently unavailable" :-\

Mind trying it again? I think it might have been some sort of temporary server error, since it looks to be up now.

yes it is working now thank you!

AvikB

  • Hero Member
  • *****
  • Posts: 732
I am currently using MusicBee 3.1 and found two issues:

Titlebar on both MusicBee main window and Preference window has weird issue.

Fluke

  • Newbie
  • *
  • Posts: 15
Hmmm, are you using a 10pt font? For some reason, I sometimes get something like that when I use the default 9pt font. (It might be a separate issue, but if anyone knows why that happens please let me know!)

Otherwise, I'm not too sure. I'm still using Musicbee 3.0.6190 (the latest non-beta patch from December 2016) and I'm not seeing any issues personally.

hello7i

  • Newbie
  • *
  • Posts: 2
Hi Fluke! I have a little problem with skin. It's on, but does not work. MusicBee ver. 3.0.6132
I don't use 10pt front, but i think it won't help with this trouble. Can you help me?

UPD: Using 10pt doesn't fix problem

Last Edit: January 15, 2017, 12:17:09 PM by hello7i

redwing

  • Hero Member
  • *****
  • Posts: 6262
Nice work!

BTW border image sizes for both skins need to be adjusted.

The border image sizes should be as follows.

FormBorderTop ------------------------------------------------- 1x28 [pixels]
FormBorderTopRight , FormBorderTopLeft ------------------ 5x28
FormBorderRight , FormBorderLeft  -------------------------- 4x1
FormBorderBottomRight , FormBorderBottomLeft ---------- 4x4
FormBorderBottom  -------------------------------------------- 1x4

Bee-liever

  • Member
  • Hero Member
  • *****
  • Posts: 2726
Hey Fluke!  Your border images are incorrect and is probably the culprit behind the problems users are having with this otherwise great looking skin.
The border elements should be in .png format with a 96 dpi value.
The dimensions should be:
Border Bottom: 4px high x 1px wide
Bottom Left/Right: 4px high x 4px wide
Left/Right: 1px high x 4px wide
Border Top: 28px high x 1px wide
top Left/Right: 28px high x 5px wide

Hope that fixes things.

EDIT:
Oops! redwing posted and I was still typing  :o
Version: 3.1.6253
MusicBee and my library - Making bee-utiful music together

AvikB

  • Hero Member
  • *****
  • Posts: 732
Hmmm, are you using a 10pt font? For some reason, I sometimes get something like that when I use the default 9pt font. (It might be a separate issue, but if anyone knows why that happens please let me know!) Otherwise, I'm not too sure. I'm still using Musicbee 3.0.6190 (the latest non-beta patch from December 2016) and I'm not seeing any issues personally.
no i am using a lots of custom font size for different panels.
Maybe it is a issue with v3.1, can't really say. :)

Fluke

  • Newbie
  • *
  • Posts: 15
Thanks all for the helpful replies! I'll try fixing my border images and will roll out a patch soon for both the skins. Hopefully will fix the title bar errors.

UPDATE: I've changed the border images and updated the download link. I must have misread the dimensions on the wiki, since all of the border elements were rotated in my initial skin (e.g. 4x1 instead of 1x4 pixels). Thanks to Bee-liever and redwing for taking the time to find out what was wrong. Let me know if that resolves the issues you guys were seeing!
Last Edit: January 16, 2017, 06:04:48 PM by Fluke

Fluke

  • Newbie
  • *
  • Posts: 15
Hi Fluke! I have a little problem with skin. It's on, but does not work. MusicBee ver. 3.0.6132
I don't use 10pt front, but i think it won't help with this trouble. Can you help me?

UPD: Using 10pt doesn't fix problem



Thanks for the comment! I think checking the "Skin Windows Borders" option under View > Skins should make the changes you're looking for. I also recommending downloading the latest version of the skin to (hopefully) fix any remaining errors with the title bar. Let me know if that works!
Last Edit: January 16, 2017, 10:09:43 PM by Fluke